Some US customers may experiece issues accessing their Workspace and message delays

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Dec 02, 2024 - 19:10 UTC

Monitoring

We’re investigating an issue that is affecting some US customers where they may run into an issue with accessing their Workspace UI, as well as message delays. We’ll update again as soon as possible.
Posted Dec 02, 2024 - 18:06 UTC
This incident affected: Message Sending and Management Interface.