fly.customer.io inaccessible

Incident Report for Customer.io Status

Resolved

A fix has been implemented and we are continuing to monitor.
Posted Jun 02, 2025 - 18:39 UTC

Investigating

We’re currently investigating reports that fly.customer.io is not accessible.
Posted Jun 02, 2025 - 18:25 UTC
This incident affected: Management Interface.