Investigating reports with intermittent loading of the drag-and-drop editor

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Mar 10, 2025 - 17:06 UTC

Investigating

We are currently investigating an issue impacting the drag-and-drop editor. The team is working on resolving the issue as quick as possible.
Posted Mar 10, 2025 - 15:38 UTC
This incident affected: Management Interface.