Account Creation Faulty

Incident Report for Customer.io Status

Resolved

The incident has been resolved.
Posted Apr 03, 2025 - 20:44 UTC

Monitoring

A fix has been implemented and the team is now monitoring the situation to ensure no further issues arise.
Posted Apr 03, 2025 - 20:42 UTC

Identified

The account creation process for Customer.io is experiencing some issues preventing the accounts from being created. The team is investigating the issue.
Posted Apr 03, 2025 - 20:01 UTC
This incident affected: Management Interface.