Delays processing send events in some environments

Incident Report for CustomerIO

Resolved

This incident has been resolved and any delays have been fully mitigated.
Posted Jul 10, 2026 - 18:08 UTC

Monitoring

A fix has been deployed and we are processing through any delay backlogs. We are continuing to monitor but expect delays to reduce shortly.
Posted Jul 10, 2026 - 17:45 UTC

Identified

We're monitoring increased load on our backend that is causing a delay in processing sends. We are actively monitoring the issue and will share updates accordingly.
Posted Jul 10, 2026 - 17:28 UTC
This incident affected: Message Sending.