Sending Delays

Incident Report for Customer.io Status

Resolved

This issue is now resolved. Message sending and access to the management interface is functioning properly.
Posted Mar 30, 2025 - 13:13 UTC

Monitoring

Some customers in the US region have experienced sending delays and access to the UI may have been intermittent. The team has found the issue, updated the system and is now monitoring.
Posted Mar 30, 2025 - 13:01 UTC
This incident affected: Message Sending and Management Interface.