Customer.io UI is currently unavailable for some customers

Incident Report for CustomerIO

Resolved

This incident is now resolved. Thank you for your patience and understanding!
Posted Apr 20, 2026 - 16:55 UTC

Monitoring

The UI is available as expected, and we are monitoring before marking this as fully resolved. Thank you again for your patience!
Posted Apr 20, 2026 - 16:50 UTC

Investigating

Our engineers are looking into an issue where some workspaces aren't loading as expected. We're working to get this resolved and will post an update soon. Thank you for your patience!
Posted Apr 20, 2026 - 16:45 UTC
This incident affected: Management Interface.