Some EU users are experiencing delays in processing

Incident Report for CustomerIO

Resolved

This incident has been resolved. Thanks a lot for your patience while we worked on a fix here.
Posted Jul 23, 2026 - 10:04 UTC

Monitoring

A fix has been deployed, and we are recovering any delayed backlogs. We are continuing to monitor the results.
Posted Jul 23, 2026 - 09:29 UTC

Identified

A fix has been implemented and we are monitoring the results. Thanks for your patience and we'll continue to update as we make progress
Posted Jul 23, 2026 - 09:16 UTC

Investigating

Our team is looking into a problem affecting UI slowness and processing delays for some EU customers.
Posted Jul 23, 2026 - 08:27 UTC
This incident affected: Data Processing and Management Interface.