Some customers are experiencing issues with saving their content

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Dec 12, 2025 - 17:25 UTC

Identified

The issue has been identified and we're working towards a resolution now. Thank you for your patience!
Posted Dec 12, 2025 - 17:20 UTC

Investigating

Our engineers are looking into this issue now. We sincerely apologize for the inconvenience.
Posted Dec 12, 2025 - 17:07 UTC
This incident affected: Management Interface.