Investigating reports of Login issues to Customer.io
Incident Report for Customer.io Status
Resolved
We have verified that the Login issue has been fixed. The incident is now resolved.
Posted Jun 20, 2024 - 12:39 UTC
Update
Our team continues to look into the issue having identified the root cause.
Posted Jun 20, 2024 - 12:23 UTC
Identified
The issue has been identified and a fix has been released.
Posted Jun 20, 2024 - 11:10 UTC
Investigating
We have received some reports of issues logging in to Customer.io using the Magic 2FA Link. Our team is currently investigating.
Posted Jun 20, 2024 - 10:28 UTC
This incident affected: Management Interface.