Intermittent issues loading Customer.io User Interface

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Jul 25, 2025 - 15:36 UTC

Monitoring

We are now seeing signs of recovery and will continue to monitor the issue.
Posted Jul 25, 2025 - 15:31 UTC

Investigating

We're are currently investigating reports of intermittent issues accessing the Customer.io User Interface
Posted Jul 25, 2025 - 15:28 UTC
This incident affected: Management Interface.