Some customers are seeing broadcast delivery delays (emails, push notifications, and webhooks)

Incident Report for CustomerIO

Resolved

We have confirmed that this incident is now resolved. Thank you very much for your patience!
Posted May 29, 2026 - 17:08 UTC

Monitoring

We have a resolution in place and are monitoring message throughput recovery now. Thank you for your patience!
Posted May 29, 2026 - 16:51 UTC

Identified

We've identified the issue and are working towards a resolution now.
Posted May 29, 2026 - 16:40 UTC

Investigating

Our engineers are aware of an issue where messages may be showing as "queued". We're investigating this now. Thank you for your patience!
Posted May 29, 2026 - 16:26 UTC
This incident affected: Message Sending.