EU Region API Processing Delays

Incident Report for CustomerIO

Update

We are continuing to investigate this and will be back again as soon as we have an update. Thank you for your continued patience!
Posted Apr 07, 2026 - 17:26 UTC

Investigating

Some customers in our EU region may be experiencing delays with processing data sent in through our API. Our team is investigating the cause and will provide an update soon. Thank you for your patience!
Posted Apr 07, 2026 - 16:46 UTC
This incident affects: Data Processing.