Segment creation delayed
Incident Report for Customer.io Status
Resolved
Service has been restored. Segment creations are now functional.
Posted Mar 29, 2023 - 18:51 UTC
Investigating
Some customers in the US region may experience delays in segment creations. No segment creation requests are lost. The CustomerIO team is actively investigating the issue.
Posted Mar 29, 2023 - 18:46 UTC
This incident affected: Management Interface.