Some US customers may be impacted by data delays and UI errors

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Oct 06, 2025 - 15:39 UTC

Monitoring

We have identified the issue and are currently monitoring a fix.
Posted Oct 06, 2025 - 15:26 UTC

Investigating

We are currently investigating an issue that may delay data processing and cause UI errors for some US customers, we do not anticipate any data loss.
Posted Oct 06, 2025 - 15:10 UTC
This incident affected: Data Processing and Management Interface.