Data processing in EU Region is delayed

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Feb 25, 2025 - 20:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2025 - 20:00 UTC

Identified

We've identified an issue in our EU Region where our servers are processing data, albeit slowly. No data is lost, data processing into workspaces is delayed, as are Transactional deliveries.
Posted Feb 25, 2025 - 19:05 UTC
This incident affected: Data Processing and Message Sending.