Some customers in our US region may experience errors and delays

Incident Report for Customer.io Status

Resolved

This incident has been resolved. We greatly appreciate your patience!
Posted Feb 23, 2026 - 20:42 UTC

Monitoring

A fix has been implemented and we're continuing to monitor for stability. Thank you for your patience!
Posted Feb 23, 2026 - 20:28 UTC

Identified

We're currently investigating an issue that may be impacting some US-based customers, potentially causing UI errors along with delays in processing and message delivery. We appreciate your patience as our team works to get this resolved.
Posted Feb 23, 2026 - 20:11 UTC
This incident affected: Data Processing and Message Sending.