Forms submissions experiencing intermittent delays

Incident Report for Customer.io Status

Resolved

The issue has now been resolved.
Posted Nov 21, 2025 - 13:09 UTC

Monitoring

The issue has been identified and our team is currently monitoring the service.
Posted Nov 21, 2025 - 12:55 UTC

Update

We are continuing to investigate the issue.
Posted Nov 21, 2025 - 12:37 UTC

Investigating

We are investigating reports of some Form submissions being delayed in the US and EU Data centers. Forms continue to function as expected.
Posted Nov 21, 2025 - 11:46 UTC
This incident affected: Data Processing.