Salesforce and Hubspot syncs might be delayed for some EU customers

Incident Report for CustomerIO

Resolved

We confirm the incident is resolved. Thank you for your patience!
Posted Jun 05, 2026 - 01:15 UTC

Monitoring

We have rolled out a fix and we're monitoring closely.
Posted Jun 05, 2026 - 00:44 UTC

Identified

We've identified an issue affecting some EU customers' Salesforce and Hubspot syncs. Our team is working on a fix.
Posted Jun 04, 2026 - 23:50 UTC
This incident affected: Data Processing.