Reverse ETL Syncs not being run for some EU Customers

Incident Report for CustomerIO

Resolved

We have confirmed that the incident has been resolved and all Reverse ETL syncs are running as expected. Thanks for your patience!
Posted Jun 01, 2026 - 12:11 UTC

Monitoring

A fix has been deployed for the issue affecting Reverse ETL syncs in EU workspaces. We are continuing to monitor this.
Posted Jun 01, 2026 - 11:44 UTC

Investigating

We are currently investigating an issue affecting Reverse ETL syncs for some EU customers.
Posted Jun 01, 2026 - 11:40 UTC
This incident affected: Data Processing.