Issues accessing EU accounts

Incident Report for CustomerIO

Resolved

This incident is resolved.
Posted Jul 31, 2026 - 14:39 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 31, 2026 - 14:33 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 31, 2026 - 14:29 UTC

Investigating

We are currently investigating an issue impacting access to EU accounts and API access. There is no impact with data processing or data loss.
Posted Jul 31, 2026 - 14:24 UTC
This incident affected: Management Interface.