Delays in loading Account Settings for some customers

Incident Report for Customer.io Status

Resolved

A fix has been implemented and the issue is resolved.
Posted Jun 27, 2025 - 13:41 UTC

Identified

Our team has identified the cause of the issue affecting a subset of our customers and is working on a fix
Posted Jun 27, 2025 - 13:04 UTC

Investigating

Our team is currently investigating reports of not being able to load the Account Settings page or access their Team Members list.
Posted Jun 27, 2025 - 12:16 UTC
This incident affected: Management Interface.