Recent Delivery Metrics not displaying for Campaigns and Broadcasts
Incident Report for Customer.io Status
Resolved
The issue was identified and resolved. No delivery metrics were lost, it was strictly a display issue with the charts and graphs for the Overview and Metric pages.
Posted Sep 22, 2022 - 19:29 UTC
Investigating
There is a UI issue with Recent Delivery Metrics not displaying on Campaigns and Broadcasts Overview/Metric tabs

Started: September 22, 2022 18:36

Severity: high - metrics are not displaying

Who is affected: All customers

Our engineers are currently looking into what is causing this, we will provide an update by UTC 19:30.
Posted Sep 22, 2022 - 19:00 UTC
This incident affected: Management Interface.