User Interface experiencing troubles loading

Incident Report for Customer.io Status

Resolved

The incident is resolved. UI is loading correctly.

Data processing as well as sending and receiving of messages was not affected during this incident.
Posted Aug 19, 2025 - 05:19 UTC

Monitoring

We have identified the issue and implemented a fix.
The systems are back online and we are monitoring availability and performance.
Posted Aug 19, 2025 - 05:06 UTC

Investigating

We are aware of UI not loading for some customers.
We are actively looking into this incident.
Posted Aug 19, 2025 - 04:48 UTC