Email status and delay issues
Incident Report for Customer.io
Resolved
Our email service provider has resolved this incident.
Posted Jun 03, 2021 - 16:16 UTC
Monitoring
Our email service provider has implemented a fix and we are monitoring the situation.
Posted Jun 03, 2021 - 14:19 UTC
Update
Our email service provider has implemented a fix and we are monitoring the situation.
Posted Jun 03, 2021 - 14:19 UTC
Investigating
We are currently investigating reports that emails are showing as sent but not delivered and have noticed that our email service provider is experiencing outbound delays.
Posted Jun 03, 2021 - 14:01 UTC
This incident affected: Message Sending.