Issue with Design Studio

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 16:16 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 08, 2025 - 16:16 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2025 - 16:12 UTC

Investigating

We are currently experiencing an issue for all customers where Design Studio is not available. We are actively investigating the issue. Message sending and processing is not affected.
Posted Oct 08, 2025 - 15:46 UTC
This incident affected: Management Interface.