Data Ingestion Degradation

Incident Report for Customer.io Status

Resolved

Backlog of data has been successfully processed. Services are operational.
Posted Jul 18, 2025 - 05:14 UTC

Monitoring

Issue has been identified and remediated. We will continue to monitor to ensure processing has recovered.
Posted Jul 18, 2025 - 04:33 UTC

Update

We have identified that data collection is fine. Data processing is still experiencing degradation. Investigation is continuing.
Posted Jul 18, 2025 - 04:16 UTC

Investigating

We are currently investigating data ingestion degradation.
Posted Jul 18, 2025 - 03:50 UTC
This incident affected: Data Collection and Data Processing.