Intermittent issues loading Design Studio for some of our EU customers

Incident Report for Customer.io Status

Resolved

This issue has now been resolved.
Posted Oct 21, 2025 - 08:53 UTC

Monitoring

Our team has released a fix for the issue. We are monitoring for any new reports.
Posted Oct 21, 2025 - 08:48 UTC

Identified

Our team has identified the cause behind the issue, and we're currently working on a fix.
Posted Oct 21, 2025 - 08:06 UTC

Investigating

Our team has received reports of intermittent issues accessing Design Studio. We're currently investigating the issue.
Posted Oct 21, 2025 - 07:39 UTC
This incident affected: Management Interface.