Some customers seeing issues with accessing Whatsapp Twilio Content Templates

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 14:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2025 - 14:24 UTC

Update

We are continuing our investigation, thank you for your patience!
Posted Jun 03, 2025 - 14:02 UTC

Update

We are continuing to investigate this issue.
Posted Jun 03, 2025 - 13:35 UTC

Investigating

We're getting reports from some customers that they're getting an error "Twilio Not Available" when trying to select a Content Template. We're investigating this issue now.
Posted Jun 03, 2025 - 12:50 UTC
This incident affected: Management Interface.