Investigation of Potential Service Disruptions

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 21:34 UTC

Monitoring

Our cloud hosting provider has mitigated the issue and their systems are recovering. We are continuing to monitor the situation.
Posted Jun 12, 2025 - 21:15 UTC

Update

Disruptions continue to be experienced by our cloud hosting provider. We are monitoring the situation closely. Data collection and data processing has not been impacted.
Posted Jun 12, 2025 - 20:20 UTC

Update

We are continuing to actively monitor the disruptions being experienced by our cloud hosting provider. Data collection and data processing has not been impacted.
Posted Jun 12, 2025 - 19:21 UTC

Investigating

One of our cloud hosting providers is suffering from major service disruptions in both US and EU. This may impact the use of our service. We are actively monitoring the situation.
Posted Jun 12, 2025 - 18:41 UTC