UI issues
Incident Report for Customer.io Status
Resolved
The issue with our user interface has been resolved.
Posted May 19, 2023 - 22:54 UTC
Update
We are continuing to investigate this issue.
Posted May 19, 2023 - 22:36 UTC
Investigating
We are currently experiencing an issue with our user interface and are investigating the cause.

We are still receiving data through our APIs and processing outbound messages.

We will continue to provide updates.
Posted May 19, 2023 - 22:35 UTC
This incident affected: Management Interface.