Webhooks are delayed

Incident Report for Customer.io Status

Resolved

The issue has been fixed and webhooks are now functioning properly.
Posted Jul 11, 2025 - 13:10 UTC

Monitoring

The team has fixed the issue and is currently monitoring to ensure webhooks are being processed properly.
Posted Jul 11, 2025 - 12:59 UTC

Identified

Some customers are experiencing a delay in webhooks being processed in the US region. The team has identified the problem and is currently working to restore the webhook functionality. No other functionality is affected.
Posted Jul 11, 2025 - 12:55 UTC
This incident affected: Data Processing.