We're currently investigating an issue with password resets and invites

Incident Report for Customer.io Status

Resolved

Thank you for your patience. We've successfully resolved this issue; you can now reset your password again without error: https://fly.customer.io/reset_password
Posted Jul 22, 2025 - 13:28 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 22, 2025 - 13:18 UTC

Investigating

Our team is looking into reports of customers getting an error when trying to join an account or reset their password. We apologize for the inconvenience and will be back with an update shortly.
Posted Jul 22, 2025 - 13:12 UTC
This incident affected: Management Interface.