Some customers in the EU having issues accessing their Workspaces

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Oct 29, 2024 - 20:24 UTC

Monitoring

We received reports that some Workspaces in our EU region were temporarily inaccessible via UI. We've identified the issue and have deployed resolution. Thank you for your patience!
Posted Oct 29, 2024 - 20:06 UTC
This incident affected: Management Interface.