This incident has been resolved. The Customer.io UI is available, and data processing has recovered to normal operating levels. We will continue internal follow-up and remediation work. Thank you for your patience.
Posted Jul 03, 2026 - 11:09 UTC
Monitoring
Processing is actively recovering. We apologize for the disruption this caused and will continue monitoring until it's fully caught up.
Posted Jul 03, 2026 - 10:25 UTC
Identified
The Customer.io UI is back online. We're continuing to work on system stability to confirm the issue is fully resolved. Processing is recovering but still delayed
Posted Jul 03, 2026 - 09:44 UTC
Investigating
Our team is currently investigating an issue where the Customer.io dashboard (fly.customer.io) is unavailable for some users in EU. We're also looking into potential data processing delays.
Posted Jul 03, 2026 - 09:07 UTC
This incident affected: Data Processing and Management Interface.