Google Adwords Outage

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 19:27 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2025 - 19:12 UTC

Investigating

We’re currently experiencing a temporary disruption in data delivery to Google AdWords. As a result, AdWords users may run into errors on the Data & Integrations page. All other integrations are operating normally.
Posted Jun 05, 2025 - 18:44 UTC