Integration Destinations UI Disruption

Incident Report for CustomerIO

Resolved

A fix has been deployed and the system's functionality is fully restored.
Posted Apr 13, 2026 - 18:31 UTC

Identified

The issue has been identified in the UI and a fix is being deployed.
Posted Apr 13, 2026 - 18:28 UTC

Investigating

Our team is aware of an issue affecting Integrations with destinations in EU/US. We are looking into this and gathering more details. Data import and export is still working, only the UI is effected.
Posted Apr 13, 2026 - 18:26 UTC
This incident affected: Management Interface.