Some customers are currently unable to access the account Billing page in our UI

Incident Report for CustomerIO

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 20:34 UTC

Monitoring

We've identified the issue and access to the Billing page has been restored. We thank you for your patience!
Posted Jun 18, 2026 - 20:29 UTC

Investigating

We're looking into an issue where https://fly.customer.io/settings/billing/ isn't loading for some customers. We apologize for the inconvenience.
Posted Jun 18, 2026 - 20:06 UTC
This incident affected: Management Interface.