Some customers are experiencing data processing delays

Incident Report for CustomerIO

Resolved

This incident is resolved. Thank you for your patience!
Posted Jul 15, 2026 - 19:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 15, 2026 - 17:51 UTC

Identified

We've identified the cause of the event processing delays and our team is working on a fix. Thank you for your patience and we'll update again as we make progress.
Posted Jul 15, 2026 - 17:35 UTC

Investigating

Our engineers are currently looking into an issue that is causing data processing delays for some customers in our EU region. Thank you for patience and we apologize for the inconvenience.
Posted Jul 15, 2026 - 17:19 UTC
This incident affected: Data Processing.