Account Creation Process Faulty

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Apr 04, 2025 - 22:21 UTC

Investigating

The account creation process for Customer.io is experiencing some issues, preventing the accounts from being created. The team is investigating the issue.
Posted Apr 04, 2025 - 21:38 UTC
This incident affected: Management Interface.