Email Delivery Delayed
Incident Report for Customer.io Status
Resolved
The issue is now resolved. The queued messages have been processed, and we are seeing normal processing speed for newer messages.
Posted Nov 23, 2023 - 15:27 UTC
Investigating
Some customers in the US region may be experiencing a delay in message processing and errors on the User Interface. The CustomerIO team is currently investigating. All data is being stored and will be processed once this is resolved.
Posted Nov 23, 2023 - 15:15 UTC