Customer.io UI and API issues

Incident Report for CustomerIO

Resolved

The issue has been resolved.
Posted Aug 18, 2025 - 22:27 UTC

Monitoring

The Customer.io UI was failing to load, and API requests were failing for certain customers. Engineers have implemented a fix and are monitoring the situation.
Posted Aug 18, 2025 - 22:06 UTC
This incident affected: Data Processing and Management Interface.