Email Delivery in EU experiencing delays
Incident Report for Customer.io Status
Resolved
This incident has been resolved.
Posted Oct 17, 2024 - 16:02 UTC
Update
The issue resolution is in place. We will continue to monitor until the email queues are cleared, bringing sending fully back up to speed.
Posted Oct 17, 2024 - 15:38 UTC
Update
We are continuing to monitor this issue and thank you for your continued patience.
Posted Oct 17, 2024 - 14:07 UTC
Monitoring
Customers in our EU region will see delays with email sending currently. The issue has been identified and we will keep our customers apprised with updates as they become available. Thank you for your patience.
Posted Oct 17, 2024 - 13:29 UTC
This incident affected: Message Sending.