Customer.io Journeys UI is not available for EU customers
Incident Report for Customer.io Status
Resolved
The issue is now resolved.
Posted Nov 29, 2024 - 13:42 UTC
Monitoring
A fix has been released, and our team is closely monitoring the system's stability.
Posted Nov 29, 2024 - 13:13 UTC
Identified
Our team has identified the root cause and we are currently working on a fix.
Posted Nov 29, 2024 - 13:05 UTC
Investigating
Our team is investigating Customer.io Journeys UI not being available for some of our customers in the EU Data Center.
Posted Nov 29, 2024 - 13:01 UTC
This incident affected: Management Interface.