Issues with user interface in EU
Incident Report for Customer.io Status
Resolved
This issue has been resolved.
Posted Sep 14, 2023 - 08:07 UTC
Monitoring
We have identified the issue with the user interface and it is back up again. We are currently monitoring it.
Posted Sep 14, 2023 - 08:04 UTC
Investigating
We are investigating some issues with our user interface in our EU datacenter. Data collection and message delivery is unaffected.
Posted Sep 14, 2023 - 07:29 UTC
This incident affected: Management Interface.