Some customers in the US are experiencing delays

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Sep 30, 2025 - 21:20 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 30, 2025 - 21:16 UTC

Identified

We have identified an issue that may cause some customers with accounts in the US to experience delays with data processing and message sending, as well as UI errors. We are working on a fix, and services should be back to normal shortly.
Posted Sep 30, 2025 - 21:10 UTC
This incident affected: Data Processing and Message Sending.