Delays in processing and UI inaccessible for some customers in the US datacentre

Incident Report for CustomerIO

Resolved

This incident has been resolved. Thanks for your patience.
Posted Aug 03, 2026 - 07:42 UTC

Update

We are continuing to investigate this issue.
Posted Aug 03, 2026 - 07:20 UTC

Investigating

Our team is currently investigating an issue that is causing some delays in data processing. This impacts a small subset of customers in the US datacentre.
Posted Aug 03, 2026 - 07:08 UTC
This incident affected: Data Processing and Management Interface.