Delays in processing requests

Incident Report for CustomerIO

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 05:17 UTC

Monitoring

5% of our customers could have experience delays up to 40minutes, but going forward everything is working correctly
Posted Jun 10, 2026 - 05:15 UTC

Update

Identified the issue, still processing backlog
Posted Jun 10, 2026 - 04:56 UTC

Investigating

Our team is aware of an issue affecting Customer IO EU and US systems . We are looking into this and gathering more details.
Posted Jun 10, 2026 - 04:45 UTC
This incident affected: Data Processing and Message Sending.