Some customers in our US region are experiencing delays

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Sep 12, 2025 - 19:18 UTC

Monitoring

We have a resolution in place now, and the backlogs are currently being processed. We'll be back with an update once the issue is all clear.
Posted Sep 12, 2025 - 19:13 UTC

Identified

Our engineers have identified that some customers may be experiencing delays with data processing and message sending. We've identified the issue and will be back with an update soon.
Posted Sep 12, 2025 - 19:02 UTC
This incident affected: Data Processing and Message Sending.