Some customers are experiencing data processing and message-sending delays

Incident Report for CustomerIO

Resolved

This incident has been resolved and all backlogs have been processed.
Posted Jul 20, 2026 - 22:58 UTC

Monitoring

A fix has been deployed, and we are processing any delayed backlogs. We are continuing to monitor the results.
Posted Jul 20, 2026 - 22:38 UTC

Identified

The issue has been identified and we're working on a fix. Thank you for your patience.
Posted Jul 20, 2026 - 22:29 UTC

Investigating

Our engineers are currently looking into an issue that is causing data processing and message-sending delays for a small subset of customers in the US region. We apologise for any inconvenience caused.
Posted Jul 20, 2026 - 21:35 UTC
This incident affected: Data Processing and Message Sending.